Subject: Important question

From: Rob Schreiber <[email-masked]>
Date: Thu, 25 Mar 93 14:46:29 PST

My notes from the last meeting do not indicate that 
the HPF_ALIGNMENT, HPF_TEMPLATE and HPF_DISTRIBUTION
(mapping inquiry) subroutines should be moved from
the intrinsics into the library, but Rick Swift recalls this.
And it seems correct and consistent with our
decision that DYNAMIC, and INHERIT, and extrinsic are not
in the HPF subset.   Since they are subroutines with
INTENT(OUT) arguments, they cant occur in specification
(or any other kind of) expressions.

Shall I move them to the library?   In the absence of
argument I will.

Rob

---

From: [email-masked] (Chuck Koelbel)
Date: Thu, 25 Mar 1993 18:16:59 -0600

My notes don't have any mention of removing the intrinsics from the subset.
 There was a discussion of moving the intrinsics/functions defined in the
HPF_LOCAL stuff out of the subset (along with HPF_LOCAL itself).

However, I agree with the reasoning that the inquiry subroutines are not
very useful without dynamic distributions or inheritance.  Moving them out
of the subset sounds good.

                                                Chuck